博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU 1005 Number Sequence
阅读量:5170 次
发布时间:2019-06-13

本文共 1051 字,大约阅读时间需要 3 分钟。

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 136403    Accepted Submission(s): 33062

Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3
1 2 10
0 0 0
 

 

Sample Output
2
5
 
 
 
 
 
 
 
 

#include<stdio.h>

int main()
{
__int64 a,b,n;
while(scanf("%I64d%I64d%I64d",&a,&b,&n)!=EOF&&(a||b||n))
{
__int64 c[105],i,k;
c[1]=1;c[2]=1;
for(i=3;i<100;i++)
{
c[i]=(a*c[i-1]+b*c[i-2])%7;
if(c[i]==1&&c[i-1]==1)
break;
}
i=i-2;
k=n%i;
if(k==0)
printf("%I64d\n",c[i]);
else
printf("%I64d\n",c[k]);
}
return 0;
}

转载于:https://www.cnblogs.com/-lgh/p/4986884.html

你可能感兴趣的文章
Linux基本命令
查看>>
测试理论
查看>>
Oracle 总结
查看>>
Python基础知识
查看>>
自动化集成环境部署
查看>>
CAS、AQS、锁以及并发工具
查看>>
volatile实现原理
查看>>
1.maven下仅shiro框架对shiro的测试使用
查看>>
【1】redis的安装和配置,以及简单的增删查改uinx命令
查看>>
2.shiro+jdbc+idea+maven数据库
查看>>
最基础eacharts图带数字,百分比,tab切换
查看>>
数组扁平化
查看>>
Gaze Estimation学习笔记(1)-Appearance-Based Gaze Estimation in the Wild
查看>>
MXNet源码解析
查看>>
优化CUDA数据传输
查看>>
AI 深度关键短语生成
查看>>
kubernetes
查看>>
AI 大规模分布式SGD:瞬间训练完基于ImageNet的ResNet50
查看>>
k8s pod
查看>>
PyTorch DataLoader
查看>>